We are aware of a potentially service impacting issue. Learn more

How to Install Sponge to a Minecraft Server Print

  • 23

Sponge is a mod that can be installed to Forge 1.8.9 and above version servers to allow servers to support Sponge plugins. Sponge plugins are very similar to Spigot/Bukkit plugins and can be found here. You cannot use Spigot/Bukkit plugins on a Forge server running Sponge. 

To install Sponge to your Minecraft server:

1. Go on your server's control panel.

2. Ensure that your server is running Forge for version 1.8.9 or above and that your server has been turned on at least once. This can be done by either installing Forge, or by installing a modpack that is version 1.8.9 or above by using this guide.

3. Once Forge is installed, go to the Sponge website and under Minecraft Version, select the version your server is running. If you're running a 1.11.2 version modpack, you'll need to download and install a 1.11.2 version of Sponge.

4. Once you have selected the Minecraft Version, under Recommended Build click Download to download that build.

5. Allow Sponge to fully download. Once downloaded, go back to your control panel and on the left-side click Files and then FTP File Access.

6. In your server's FTP, click to enter the mods folder.

7. In the mods folder, click Upload File at the top of the FTP.

8. Locate the Sponge-Forge mod file you downloaded and drag-and-drop that file into the upload area to upload that file.

9. Once that file has finished uploading, on the left-side of your FTP click Back to Control Panel to exit your FTP and then click Restart on your control panel to restart your server.

You have now successfully installed Sponge to your Minecraft server!


To check to ensure Sponge is installed properly, in your console type the command sponge. If your console returns output and does not say Unknown Command, Sponge has been installed properly!


Important Information:

  • Sponge-Forge may experience conflicts with other Forge mods, such as FoamFix, causing constant server crashing until Sponge is removed.

  • Sponge-Forge may conflict with core mods in a modpack, causing Sponge to refuse to load.



Experiencing issues installing Sponge or unable to locate the proper Sponge version for your server? You can submit a ticket or contact our Live Chat team and we would love to help you!


Was this answer helpful?

« Back